I have a HTC HD2 mobile phone from T-Mobile (UK).  Recently, I updated the phone which went smoothly and retained all my content and settings.  However the next morning, I discovered that the time had gone back 5 hours and I started having all sorts of fun with my appointments.  When I went into “Local Time Settings”, I found that the “City” settings (where you define the timezone) were set to GMT-5 and greyed-out – meaning that I couldn’t correct the timezone!

Obviously, I couldn’t have survived with this situation lasting so I started looking and playing with different settings.  Fortunately, I was able to find a workaround.  It goes something like this:

  1. Go to “Today” screen and tap the time display,
  2. When “World Clock” is displayed, tap on “Add City”,
  3. Start typing your city’s name and when displayed, select it,
  4. Once added to the list, change from “My Location” to your city,
  5. Go to “Local Time Settings” and confirm that the timezone is now set correctly,
  6. Go back to “World Clock” and select “My Location” again.  This time, it should remain set correctly.  You could also optionally remove the added city from the list now.

This fixed the problem for me and hopefully it’ll be of some use to anyone having this problem.